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1. ABSTRACT 

 
Raman spectroscopy is widely used in the field of geosciences because it is very fast, non-

destructive, noninvasive and does not require sample preparation. The Raman spectra often 
provide unique fingerprint of the sample that can be used to identify any unknown minerals. 

Raman Data Search and Storage (RDSS) software was developed as an analytical tool 
for a fast and accurate identification of unknown minerals by comparison of their spectra with 
the indexed library of data. RDSS is a freeware, user-friendly software, written in Java, not OS 
dependent, available for use by anyone who has an Internet connection and can be accessed at 
the following link:  http://rdss.sf.net. A search function was implemented to enable users to find a 
specific peak value. Using the asterisk character (*) as a placeholder for one or more unknown 
peak value(s), the software will return the best match(es). Besides the search utility by the Raman 
band positions, which was proven to be priceless in the interpretation of Raman spectra, the 
RDSS software gives the user the ability to display and inspect the Raman spectra quickly and 
very efficiently. Users can zoom into the Raman spectrum, shift in any direction the wavenumber 
and the intensity axes, and if any part of the spectral display is clicked, that region will be 
highlighted and the specific wavenumber returned. A photo for every sample entry stored in the 
database is also available. For the raw Raman spectra, the RDSS software can open any .txt file 
format with XY data format, delimited by different delimiters: tab, space, comma, semicolon, and 
it can also ignore rows with ##comments. 

The RDSS software allows users to easily find the Raman peaks of a raw spectrum 
obtained from a single crystal or from a mixture where multiple peaks are expected to arise. The 
only disadvantage encountered in most applications which use a spectral matching system is 
usually the insufficient number of spectra in the database. However, even with a limited number 
of records in the database, the user can obtain a first impression of the mineral class of the 
unknown compound. 
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2. GENERAL DESCRIPTION 
 

2.1. Description 
Raman Data Search and Storage (RDSS) software was developed as an analytical tool 

for a fast and accurate identification of unknown minerals by comparison of their spectra with 
the indexed library of data. This application derives from an online database entitled Romanian 
Database of Raman Spectroscopy (RDRS). RDSS is freeware, enjoy! 

 
2.2. System Requirements & Installation 
2.2.1. Terms of Use / before start (takes 10 seconds) 
Please, read END-USER LICENSE AGREEMENT (EULA) carefully before copying, 

installing or using the RDSS software. By using all or any portion of the Software you accept all 
the terms and conditions of this Agreement. If you do not agree, do not use this Software. 
You can read the EULA online, at this URL http://rdss.sf.net/license.html; or, you can read the full 
EULA which is in the root directory of the application (LICENSE.txt). 

 
2.2.2. Download 
You can download it from application website (http://rdss.sf.net/download.html), or from 

the sourceforge website (http://sourceforge.net/projects/rdss/). 
 

2.2.3. Installation 
This is written in Java, so you don't need to install it, just take care if you have JAVA 

Runtime Environment. You can find Sun's Java here (http://java.com/download/). By the nature of 
what it does and for what it’s used, it is not portable at all, and only runs on Windows (tested on 
XP, Vista 32/64, Windows 7 32/64). It works on Linux OS, but not fully functional! Minimum 
hardware requirements: RAM 512 MB (1GB recommended). 
 
 2.3. Scientific citation 

If you use RDSS in your scientific work, please reference to the software as: 
 
"RDSS - A Raman spectra library software using peaks position for fast and accurate 
identification of unknown inorganic compounds", Version 201x.xx.xx, 
http://rdss.sourceforge.net. 
 

Important! Please insert the current version number which is presented as date format 
yyyy.mm.dd. 
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3. THE GUI (GRAPHICAL USER INTERFACE) 
 
3.1. Menus 
General functions are accessed via the Menus.  
  

Main Window //Menu New Spectrum //Menu 
Function Shortcut Action event Function Shortcut Action event 

File > Login F5 Disabled at this 
moment* File > Clear Spectrum Ctrl + R 

Clear the 
spectrum from 
the ChartView 

File > Open Spectrum Ctrl + N Open a new file 
spectrum File > Exit Ctrl + Q Close the 

window 

File > Save Spectrum Ctrl + S Save the current 
spectrum Spectra > Properties Ctrl + E Properties of the 

spectrum 

File > Refresh Ctrl + Alt + 
R 

Restart the 
application Spectra > 

RIA 

Baseline 
adjusted Ctrl + B 

Open ‘baseline 
adjusted’ tab for 
RIA 

File > Exit Ctrl + Alt + 
Q 

Quit without 
prompt message 

High 
fluorescence Ctrl + H 

Open ‘high 
fluorescence’ tab 
for RIA 

Window > Reset 
Layout F3 Reset all panels    

Help > Help F1 Open this file    
Help > Quick Start 
Guide Ctrl + G Open a quick start 

guide    

Help > Support Forum F11 Open the Forum 
webpage    

Help > License Alt + L Open License file    
Help > Change Log F12 Open Change log    

Help > Roadmap  Open Roadmap 
page    

Help > Check for 
update Ctrl + U It checks for any 

updates    

Help > Donate  Open donation 
page    

Help > About F2 Open About 
window    

* - Login function is disabled at this moment because administrator panel require some technical adjustments. 
 

3.2. Main window 
 

 
Figure 1 - Main window of the Raman Data Search and Storage application: a) – ChartView panel; b) – 

data entries panel; and c) – panel with the details of the selected entry from panel 2 
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3.2.1. Data entries, ChartView and tentative assignment of the Raman peaks 
The core of the RDSS application GUI is the bottom, where two tabbed panels contain 

two tables. First tab named Primary Table contain a table designed to have commons columns like: 
sample no., mineral name, chemical formulae, main peaks, other peaks, reference, external link 
and comments. The second tab named Secondary Table, contain a table designed to have a more 
specific columns for specific domain search: mineral name, 200 - 600 cm-1, 600 - 900 cm-1, 900 - 
1200 cm-1, 1200 - 1500 cm-1, 1500 - 2000 cm-1, 2000 - 3000 cm-1, 3000 - 4000 cm-1, external link, 
comments and reference (see figure 1). The first and the last three columns are linked with those 
from Primary table for structure reasons. 

In the left-upper part of the main window of RDSS application, a Raman spectrum 
shows when a specific row is clicked in the Primary and Secondary Table. In other words, each 
mineral row is linked with its own Raman spectrum. 

 
3.3. New Spectrum window 
 

 
Figure 2 – New Spectrum window of the Raman Data Search and Storage application: a) – ChartView 

panel; and b) – a panel which contain tabs with specific functions 
 
 
 3.3.1. Analyze 
 In this tab user can manually extract the interested peaks or automatically which is a great 
function for Raman spectra with multiple peaks. See bellow discussions for both options. 
 
 3.3.1.1. Manual 
 When “Manual” radio button is pressed, a panel with manual search function of the 
Raman peaks becomes active (figure 3). 
 After the "Get Peaks" checkbox is checked, on the Raman spectra chart panel appear a 
crosshair which moves with the mouse crosshair. In other words it's like a real-time mouse 
tracing which help the user to get the exact peak position. Furthermore, the user can zoom in 
before get the desired peak. All peaks appear in a list with different options: delete a single peak, 
multiple or even all peaks from the list. 
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To compare selected peak(s), after selection, press “Go” button from the bottom of the 
entire panel.  
 

 
Figure 3 – Manual search function of the Raman peaks 

 
 
 
 3.3.1.2. Automatic 

When “Automatic” radio button is pressed, a panel with automatic search function of the 
Raman peaks becomes active (figure 4). 
 

 
Figure 4 – Automatic search function of the Raman peaks while set the value of the “Threshold” 

 
To use the automatic search function, the user needs to fill two variables before obtaining 

peak values. 
First variable is the “threshold”. Specify the 'threshold' heigh, 'findpeaks' only returns 

peaks that exceed at least the Y-value of 'Threshold' (figure 4).  
 
Second variable is the “Gap”. Specify the 'gap' width. This function affects number of 

peaks. Density of the peaks is directly correlated with this variable. Most recommended values are 
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between 50 and 300. In this example (figures 4 and 5), was used a value of 200. Don’t forget to 
press “Find” button after you filled the second variable. 

All peaks appear in a list with different options: delete a single peak, multiple or even all 
peaks from the list. To compare selected peak(s), after selection, press “Go” button from the 
bottom of the entire panel. 
 

 
Figure 5 – Automatic search function of the Raman peaks after was set the value of the “Gap” and “Find” 

button was pressed 
 
 

3.3.2. Relative Intensity Assignment (RIA) 
 This function is performed for both the Baseline Adjusted Raman spectra and for Raman 
spectra with High fluorescence. For both functions is used a 5 steps of intensity assignment and 
are divided as follow: 
 

Intensity Assignment 
between 0 – 10% very weak (vw) 
between 10 – 30% weak (w) 
between 30 – 60% medium (m) 
between 60 – 90% strong (s) 
between 90 – 100% very strong (vs) 

 
 The Baseline adjusted Raman spectra (figures 6 and 7) works very well with baseline-
removed spectra. After the checkbox "On/Off | Intensity Assignment" is checked, the user must 
extract the strongest peak by moving the crosshair and press first mouse-button on that peak 
(figure 6). Afterwards, the lowest peaks (in terms of intensity) can be assignet based on the 
strongest peak. 
 The High fluorescence Raman spectra (figures 8 and 9) works very well with the Raman 
spectra which has no baseline-removed spectra. After checkbox "On/Off | Intensity 
Assignment" is checked, the user must extract the strongest peak in two steps: 

(i) first identify the highest peak from the Raman spectrum and check the 
“Min” (which stands from “minimum”) radiobutton, afterwards the 
user must extract the minimum of the strongest peak by moving the 
crosshair and press first mouse-button on that minimum of the peak 
(figure 8); 
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(ii) the second step is similar to the first, the difference being that the user 
must to check the “Max” (which stands from “maximum”) 
radiobuutton, afterwards the user must extract the maximum of the 
strongest peak by moving the crosshairr and press first mouse-button 
on the maximum of the peak. 

For the Peak 1 assignment, the procedure is similar to that of the extraction intensity 
value for the “Strongest peak” (discussed above). 
 

 
Figure 6 – Relative Intensity Assignment (RIA) in action for a Baseline adjusted Raman spectrum. 

Obtaining the “Strongest peak” intensity value 
 

 
Figure 7 – Relative Intensity Assignment (RIA) in action for a Baseline adjusted Raman spectrum. 

Obtaining the “Peak 1” Intensity Assignment based on the “Strongest peak” intensity 
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Figure 8 – Relative Intensity Assignment (RIA) in action for a High fluorescence Raman spectrum. 

Obtaining the minimum intensity value of the “Strongest peak” 
 

 
Figure 9 – Relative Intensity Assignment (RIA) in action for a High fluorescence Raman spectrum. 

Obtaining the maximum intensity value of the “Strongest peak” 
 
 3.3.3. Appearance 
 The Appearance panel (figure 10) contains a lot of tools to manipulate the Raman spectrum in 
terms of appearance. These tools are described in the following table: 
 

Tool Action 

Tick spacing Fill the textbox with the desired space between 
ticks for both axes (Wavenumber and Intensity) 

Gridlines Check or uncheck the checkboxes for the desired 
axis to show or hide the gridlines 

Range 
Fill the textboxes from x (start number) to y (end 
number). Don’t confuse y with Y axis. This range 

can be used just for the Wavenumber axis. 

Spectrum color 
User can choose a color from 7 available colors 

(black, red, green, blue, orange, yellow and cyan). 
Default is black. 
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Spectrum width Width of the Spectrum line 

Spectrum points/lines Convert the Raman spectrum line in points linked 
by a thin line and default Raman spectrum line 

Reverse axes Checkbox to reverse X-axis (Wavenumber) and 
checkbox to reverse Y-axis (Intensity) 

 
  

 
Figure 10 – Functions from the Appearance panel tab in action 

 
3.4. Spectra menu and properties 

 The Chart Panel where is shown the Raman spectrum has some functionalities and 
properties which can be archieved by mouse actions. 
 Right mouse click activates a popup menu with the following items: 
 

Item Action 
Copy Copy the Raman spectrum (you can paste it in 

photo editors) 
Save as… Save the Raman spectrum in .png format 
Print… Print it 
Zoom in > Both Axes Zoom in perserving the ratio of both axes 
              > Domain Axis Zoom in perserving just the Intensity ratio  
              > Range Axis Zoom in perserving just the Wavenumber ratio 
Zoom out > Both Axes Zoom out perserving the ratio of both axes 
                 > Domain Axis Zoom out perserving just the Intensity ratio  
                 > Range Axis Zoom out perserving just the Wavenumber 

ratio 
Auto Range > Both Axes Auto Range both axes 
                   > Domain Axis Auto Range Wavenumber axis  
                   > Range Axis Auto Range Intensity axis 
Reverse X-axis  Reverse Wavenumber axis 
Help/Shortcuts Opens a window with explainations of how to 

use mouse for a fast and easy controlls of the 
Raman spectrum 
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Figure 11 – Spectra menu and properties 

 
 

Action How to do it 
Zoom in/out Use the scroollwheel-up/down of the mouse 
Zoom in on a desired region Use the left mouse button to drag a selection 

rectangle 
Restore X-axis / Y-axis Press right mouse button and drag the mouse 

up/down 
Translate X-axis / Y-axis Ctrl + left mouse button and drag the mouse 

to move the whole Raman spectrum 
Get X value press left mouse button on the Raman 

spectrum and hover the mouse to see the 
specific value of the X axis 

 
 
4. FUTURE DEVELOPMENT 
  
- to populate the application with new Raman spectra; 
- integrate 3D crystal structure for every entry; 
- save spectra in .csv / .xls format 
- drag and drop spectrum file; 
- add clear button for RIA panel; 
- mineral classes description; 
- Raman introduction/tutorial/short presentation; 
- google maps api, for GIS coordinates of the samples. 
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